Archivi tag: wireless

dscf1289.jpg

Mac, beacons e saltellamenti…

Brand new WRT54GSNon molto tempo fà, il router wireless di casa mia ha dato i primi segni di cedimento, quasi comprensibili dopo 4 anni di uptime costante e traffico sostenuto come quello che un tecnico come il sottoscritto può fare.

Dopo una rapida analisi della situazione, ho deciso di fare un “pesante investimento” ed acquistare un nuovo router wireless, optando per un Linksys della serie wrt (quelli su cui eventualmente si può mettere Linux), recuperato da MediaWorld per la modica cifra di un centinaio di euro.

L’occasione è stata buona anche per mettere in sicurezza la rete wireless domestica, che fino a non molto tempo fà veniva protetta semplicemente da un filtro sul mac-address e dal fatto di restare “nascosta” (non inviava beacons): con l’introduzione del nuovo router, ho deciso di consentire che l’access point inviasse i suoi bei beacons, e ho deciso di proteggerne l’accesso utilizzando wpa.

Spulciando poi tra le opzioni “avanzate” del software in dotazione alla Linksys, ho scoperto la possibilità di ridurre il rate con cui i beacons vengono inviati, e mi sono detto: “A che prò inviare un beacon ogni 100 millisecondi come impostato di default?”, e ho così ritoccato l’impostazione facendo inviare un beacon al minuto, più che sufficiente perché un utente interessato noti la presenza della rete, ma allo stesso tempo adatto a rendere meno semplice l’individuazione dell’access-point da parte di un eventuale war-driver.

Naturalmente, Linux non ha fatto una piega, recuperato il nome della rete, richiesto la password, e connesso.
Nell’atto di configurare il MacBook della mia dolce metà, invece, mi sono reso conto che la connessione dell’AirPort andava su e giù, al punto da non riuscire neppure a caricare per intero la homepage di Google.

Dopo qualche tentativo, individuo proprio nel “beacons rate” la causa di questo strano comportamento, e le prove successive (con beacons rate progressivamente ridotti) hanno portato al ripristino dell’impostazione di default del Linksys (100 ms), prima che il MacBook decidesse di teneresi la connessione attiva costantemente.  Non so se il problema fosse già noto o segnalato (anche perché dalle ricerche di Google che ho fatto non ho trovato nulla di significativo) ne ho fatto prove ulteriori per verificare la riproducibilità del problema.

Se qualcuno ha voglia di approfondire… 🙂