WordPress 2.7

wordpress-27E’ stata rilasciata la versione 2.7 di WordPress, il software di blogging più usato. Tra i cambiamenti più visibili, indubbiamente c’è l’interfaccia di amministrazione, completamente ridisegnata e, per quel poco che ho potuto vedere, davvero di notevole qualità.

Apparentemente ancora più semplice da usare e da installare, la nuova versione di WordPress non farà che confermare, a mio avviso, la giustificata leadership del settore. La difficoltà di chi occupa il primo posto è sempre il compito di dover tracciare la via e gli sviluppatori di WordPress non si fanno pregare 🙂

Inutile aggiungere che ho già fatto l’aggiornamento alla nuova release senza incontrare alcun problema (l’unico “disturbo” era legato ad una versione non aggiornatissima del plugin Simple-Tag), e che conquesto post provvedo di fatto ad inaugurare la nuova piattaforma 🙂
Dovrei a breve avere, tra l’altro, la possibilità di fare del lavoro di customizzazione pesante (già fatto per quanto riguarda la versione 2.6); sarà divertente scoprire se qualcuna delle problematiche che ancora WordPress aveva in termini di customizzazione sono nel frattempo stati in qualche modo corretti…

Annunci

3 pensieri su “WordPress 2.7

  1. G.

    Per “Simple Tags” è sufficiente un ritocco al codice PHP per renderlo funzionante – anche se non compatibile al 100% con la nuova interfaccia: ovvero, funziona, ma non si possono spostare i box del plugin in giro per la pagina di amministrazione.

    Il ritocco da fare è cambiare l’inizio della funzione Check_version aggiungendo la menzione alla versione 2.7 (confrontalo con il file corrente e vedi subito)

    // Check version.
    global $wp_version;
    if ( strpos($wp_version, ‘2.5’) !== false || strpos($wp_version, ‘2.6’) !== false ||
    strpos($wp_version, ‘2.7’) !== false ) {
    require(dirname(__FILE__).’/2.5/simple-tags.client.php’);
    } elseif ( strpos($wp_version, ‘2.3’) !== false ) {
    require(dirname(__FILE__).’/2.3/simple-tags.client.php’);
    } else {
    function simple_tags_warning() {
    echo ‘‘.__(‘Simple Tags can’t work with this WordPress version !’, ‘simpletags’).’ ‘.sprintf(__(‘You must use Simple Tagging Plugin for it to work.’, ‘simpletags’), ‘http://wordpress.org/extend/plugins/simple-tagging-plugin/’).”;
    }
    add_action(‘admin_notices’, ‘simple_tags_warning’);
    }

    Spero comunque che venga presto pubblicato un aggiornamento “vero”.
    Ciao.

    Rispondi

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...