Giocando con Logo

L’altro giorno, mentre mi passava tra le mani una eduKnoppix su cui lavorare, mi sono imbattuto in KTurtle. Avendo un po di tempo, mi sono messo a giocare con il Logo, che devo dire potrebbe essere un ottimo “linguaggio” con cui far cominciare a programmare dei bambini delle medie. Davvero simpatico.
Il codice che ho scritto altro non fa che disegnare una casetta, parametrizzando qualche dato.

# Configurazione della casa
altezza_casa=120
larghezza_casa=160

inclinazione_tetto=60 lunghezza_tetto=93
altezza_porta=50 larghezza_porta=40
altezza_finestre=40 larghezza_finestre=40
# Ripuliamo tutto. Per esecuzioni continue. ricomincia
# Impostiamo lo sfondo dimensionesfondo 200,200 spessorepenna 1
# Disegnamo il quadrato inferiore vai 20,180 ripeti 2 [ avanti altezza_casa destra 90 avanti larghezza_casa destra 90 ] direzione 0
# Andiamo a disegnare il tetto # TODO: calcolare inclinazione_tetto e lunghezza_tetto a partire da "altezza_tetto" (trigonometria)
vai 20,60 ripeti 2 [ destra inclinazione_tetto avanti lunghezza_tetto ] direzione 0
# Porta... vai 85,180 ripeti 2 [ avanti altezza_porta destra 90 avanti larghezza_porta destra 90 ] direzione 0
# Finestre... vai 30,80 ripeti 2 [ destra 90 avanti altezza_finestre destra 90 avanti larghezza_finestre ] direzione 0
vai 130,80 ripeti 2 [ destra 90 avanti altezza_finestre destra 90 avanti larghezza_finestre ] direzione 0
# Torniamo a casa vai 160,190 direzione 270
Annunci

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...